Créer une application Facebook avec le Facebook PHP SDK v4

2014, May 29    

Cela fait un ou deux mois désormais, Facebook a lancé une nouvelle version de son SDK PHP. Il s’agit désormais de la v4. L’ancienne version fonctionne encore sans soucis, mais je vous conseille tout de même de passer sur cette nouvelle version.

/!\ La V4 du SDK Facebook demande PHP 5.4 ou supérieur.

Ayant joué un peu avec depuis sa sortie, je publie ici un petit article pour vous montrer comment démarrer. J’ai installé le SDK avec composer.

Avec un simple composer.json :

{
  "require" : {
    "facebook/php-sdk-v4" : "4.0.*"
  }
}

Puis :

php composer.phar install

Vous voilà désormais avec le SDK dans votre dossier. Voici le code pour démarrer avec :

(si l’embed du gist ne fonctionne pas –> https://gist.github.com/rkueny/6db5a611c796762221d9 )

Vous trouverez d’autres exemples ici : https://developers.facebook.com/docs/php/gettingstarted/4.0.0

Je ne vois pas trop quoi ajouter, si vous avez des questions, n’hésitez pas à laisser un commentaire.